Ava-368: Permissions not enforced on certain Ava Aware APIs

Release Date

18th January 2021.

Overview

Permissions were not correctly enforced on certain Ava Aware APIs, allowing any authenticated Aware user to retrieve anomaly detector configuration and anomaly detector models.

Affected Products

  • Ava Aware:
    • All Stable upgrade channel versions before 3.3.5.
    • All Beta upgrade channel versions before 3.3.5.

Unaffected Products

  • Ava Aware:
    • All Stable upgrade channel versions after and including 3.3.5.
    • All Beta upgrade channel versions after and including 3.3.5.
  • Ava Cameras: All versions.
  • Ava Cloud: All versions.

Resolution

This issue has been fixed in Ava Aware Beta upgrade channel version 3.3.5 and Stable upgrade channel version 3.3.5.

We strongly recommend that all installations running an affected version are upgraded to the latest release as soon as possible. Releases are available to download through the Ava Aware User Interface.

Vulnerability Information

Mitigations

There are no known mitigations for this issue.

Work arounds

There are no known work arounds for this issue.

Acknowledgements

Issue found internally by Ava Security.

Disclosure Timeline

  • 12/01/2021 Issue found internally by Ava Security
  • 12/01/2021 Root cause established
  • 14/01/2021 Fix identified
  • 18/01/2021 Patched Ava Aware (Beta upgrade channel) released
  • 18/01/2021 Patched Ava Aware (Stable upgrade channel) released
  • 18/01/2021 Vulnerability publicly disclosed